installation  »  requirements


At a minimum, the Pop PHP Framework requires PHP 8.1, but it has been built for and tested with PHP 8.2. So the only true requirement is that to have at least PHP 8.1 installed in the environment.

As of Pop PHP Framework version 5.0.0, PHP 7.4 is no longer supported.


Various components of the Pop PHP Framework require different PHP extensions and components to function correctly. If you wish to take advantage of the many components of Pop PHP, the following is recommended:

  • mysqli
  • pdo_mysql
  • pdo_pgsql
  • pdo_sqlite
  • pdo_sqlsrv
  • pgsql
  • sqlite3
  • sqlsrv
  • gd
  • imagick
Caching, Queueing & Debugging:
  • apcu
  • memcached
  • redis
HTTP, Auth & Others:
  • curl
  • ftp
  • ldap
  • json
  • simplexml